NAVIII USB Driver Install Assist - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Sep 10th, 2006, 11:35 pm Thread Starter
Senior Member
 
BCVBeck's Avatar
 
Join Date: Aug 2006
Location: Hanford, CA, USA
Posts: 294
Question NAVIII USB Driver Install Assist

Greetings All,

I've installed the software that came with my NAVIII unit onto my laptop, no problem. The instructions for the GPS said I should load the USB drivers PRIOR to connecting to my computer. Trouble is, I don't see any application on the CDROM to get 'er done. I see a sub-folder on my hard drive that appears to contain the necessary drivers. Did the install program upload the USB drivers automatically? Just curious. Will probably end up just connecting the NAVIII to my computer to see what happens. Any experience?

Bruce


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bruce

BMW MOA# 130127
IBA# 49203
MSF RiderCoach
USN (Retired)

'13 R1200GSA (Magma Red)

"Life, Liberty, and the Pursuit of All Who Threaten It."


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BCVBeck is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Sep 11th, 2006, 11:08 am
 
Join Date: Feb 2004
Posts: 4,905
Go ahead and connect the NavIII up to the PC. When it asks for drivers, point to that sub-directory, or insert the CD. Either should work.
messenger13 is offline  
post #3 of 5 Old Sep 11th, 2006, 11:13 am Thread Starter
Senior Member
 
BCVBeck's Avatar
 
Join Date: Aug 2006
Location: Hanford, CA, USA
Posts: 294
Thanks Joe,

I'll get 'er done tonight.

Bruce


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bruce

BMW MOA# 130127
IBA# 49203
MSF RiderCoach
USN (Retired)

'13 R1200GSA (Magma Red)

"Life, Liberty, and the Pursuit of All Who Threaten It."


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BCVBeck is offline  
 
post #4 of 5 Old Sep 11th, 2006, 7:18 pm Thread Starter
Senior Member
 
BCVBeck's Avatar
 
Join Date: Aug 2006
Location: Hanford, CA, USA
Posts: 294
Talking Too Easy!

Joe,

Worked just like you said it would. Pretty slick! Believe it or not, I wasn't even concerned about GPS when I walked into the showroom after dropping off my Montauk for serive. Talk about fantastic timing. NEVER would have been able to PLAN something like this. Anyway, thanks again for your encouraging words.

Bruce


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bruce

BMW MOA# 130127
IBA# 49203
MSF RiderCoach
USN (Retired)

'13 R1200GSA (Magma Red)

"Life, Liberty, and the Pursuit of All Who Threaten It."


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BCVBeck is offline  
post #5 of 5 Old Sep 11th, 2006, 7:32 pm
 
Join Date: Feb 2004
Posts: 4,905
Once you have a GPS, there's no going backl!
messenger13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
PIAA 1100x Electrical Install Safedog K1200LT 2 Aug 31st, 2006 4:01 pm
Adventure Winglets Install amarider GS Series 4 Jul 15th, 2006 11:35 pm
SmarTire Install questions.. jackd Other Stuff 8 May 31st, 2006 11:08 am
Factory Top Trunk Luggage Rack Install Crestwood330 K1200LT 7 Jan 2nd, 2006 8:57 am
J-Peg Install Problem TomMoss Ergonomics & Rider Comfort 4 Oct 12th, 2005 9:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome