faild brake servos - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Apr 23rd, 2010, 2:58 pm Thread Starter
Junior Member
 
Join Date: Dec 2009
Location: greenfield, , uk
Posts: 6
faild brake servos

on two occasions I have had brake servos failing on my k1200lt,it is an intermitant fault,it first happend four weeks ago two bmw dealers looked at the bike and said there was no fault so did not do any repair.I have had the bike back two and a half weeks and the problem has reoccured so there is definately a potentialy a serious problem.When this happens all is fine as I ride the bike them the red warning triangle and the brake failure warning start to flash followed by the servos stopping working,resulting in a drastic loss of brake power.If you turn off the ignition and leave a couple of mins and switch back on the brake system resets and is fine for a few miles,then reoccurs,I have done about 500 miles between the two events.One bmw dealer has refused to look at the bike,and is now at another bmw dealer,the bike is under a bmw warranty.I contacted bmw customer services and was told they cannot help,if the dealer cannot find the fault.
Has this happend to anybody else,meaning the brake servo problem and did you get it resolved.The person at bmw customer services said I was gettig over dramatic stating that a brake failure could result in serious injury or even death.
Johnsadd is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Apr 23rd, 2010, 3:40 pm
Senior Member
 
Join Date: Mar 2005
Location: Palma de Mallorca
Posts: 1,985
Re: faild brake servos

How´s your battery ?.
simoncharles is offline  
post #3 of 4 Old Apr 23rd, 2010, 4:58 pm
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Re: faild brake servos

I had similar prob when new. Brake servo failed and I rolled out into oncoming traffic.... that's pretty serious.

My dealer replaced the unit.. and the problem never reappeared.

I did note, however, when this happened when bike was new and the original battery lasted less than a year... Voltage would drop irregularly... and it turns out, after replacing the battery that the brake perf. improved... and lots of "gremlins" disappeared.

If you want to be "sure".. the battery must be "load tested", not just voltage... IMHO.

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
 
post #4 of 4 Old May 19th, 2010, 9:29 am
Junior Member
 
Join Date: Jun 2008
Location: Novi Sad, , Serbia
Posts: 18
Re: faild brake servos

My Servo failed on a 2001 riding along at 90 mph brake fail light came on and there was no braking at all front or rear. Got to the next service station and could not stop the bike even when at walking pace had to use my feet and it bumped into the curb. After much agro got it recovered to a BMW owned workshop in Germany. They said impossible for the brakes to fail. As the main mechanic rode down the ramp to the workshops guess what brakes failed completely. He came up to me and whispered that officially he has to say impossible but he said that they had failed completely.

Much trouble later I got a 2nd hand ond from USA for €400 deliverd to Germany. I then fitted it and bled it ect.The BMW workshop were fantastic and very helpfull unoficialy of course.

Until somebody spends alot of money and time proving that they fail BMW will not admit it as we have no proof. If a bike crashed due to this identifiying this prob with a wrecked bike would be nearly impossible. BMW have worked all this out.
itsallpoo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Brake Problem and a Near Miss chuckle K1200LT 31 Mar 14th, 2016 12:56 pm
Rather longish, but good tips & info! vvk Bike Talk 7 Jun 19th, 2011 5:43 pm
Speed Bleeders and DOT 5 atrovarious K1200LT 11 Jun 24th, 2010 10:27 pm
No rear brake??? JCarver K1200LT 9 Aug 13th, 2007 11:36 am
Front Brake Pad R&R (looong story) was K1200LT 1 Sep 3rd, 2006 11:48 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome