2002 GMC Yukon XL won't start - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old Mar 3rd, 2008, 9:59 pm Thread Starter
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
2002 GMC Yukon XL won't start

I know this is a MC forum, yet, there are similarities in car and LT systems... any help is appreciated.

Sunday, My 2002 GMC Yukon XL (yes, it's mine now that it is broken), fails to start.

Before I returned home, the fuel pump was diagnosed as having croaked and my sons have the tank partially dropped, and had the pump out. the new one did not quite seem right.. but what do I know.

Since I'm fighting the flu and respiratory distress, I go inside and await their frustration level to threshold..

An hour later they step up and say, "They gave us the wrong pump"... hmmm

Another 1.5 hours and they have returned with another "new pump" and start assembly into tank.

I go outside to make sure my prodigy are not smashed under the vehicle and ask them... "did you hook it up to make sure it runs?" .002 seconds later I get the "WTF???" look, so I just shut up and go back inside.

Another 1.2 hours and they are about to set fire to the tank because they can't get the retaining ring in place.

.1 hours later I (stupid old man) get the ring in place with a light touch of silicone spray between the ring and gasket...

.5 hours later it's all back together, Battery connected.... ready to crank... Turn igniton "on"... no fuel pump noise... no fuel gauge reading.... (there was about 1/8 tank before replacement)

We "swapped" relays around, checked fuses.. etc... noting "obvious"....

So, I'm still laid up, trying to keep breathing.. my oldest borrows a "test" device and checks the car.. there are NO errors.. zero. But, still no "vroom".

Before I pull the tank completely...again... when I get over a little bit of this illness, what do you guys think the problem is?
1- Faulty "new" pump
2- problem with wiring to pump
3- ECM
4- "other"?

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old Mar 3rd, 2008, 10:07 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,117
Re: 2002 GMC Yukon XL won't start

Cycle the pump a few times and check the schreader valve on the fuel rail - should be about 40 psi if you have a gage - if not it should squirt out of there like gang busters. If that is OK check for spark. Pull a plug wire and insert a screw driver and hold close to ground look for arc. I had a similar problem with my 96 lincoln and it defied me with no spark. I was ready to change out the crank sensor when a buddy suggested a hard reset of the ECM. Did the old "LT radio reset" by disconnecting the battery to hard reset the ECM and it fired right up. Hope you are as lucky.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 14 Old Mar 3rd, 2008, 10:09 pm
Senior Member
 
sheldan2's Avatar
 
Join Date: Mar 2005
Location: kings mountain, NC, usa
Posts: 2,099
Re: 2002 GMC Yukon XL won't start

Some cars have a safety shut off to the fuel pump, or something to that effect. might be something worth enquiring as to whether yours has one installed. I know my ford has one, just never bothered to look for its location.
sheldan2 is offline  
 
post #4 of 14 Old Mar 3rd, 2008, 10:14 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,117
Re: 2002 GMC Yukon XL won't start

Oops I see you have a fuel pump not running situation. I have traced that to a melted wire (BMW sedan under rear seat) to corroded connector up under the hood on a ford explorer. Aside from the requisite fuse checks - try to trace the wiring back and look for corrosion on all the connectors. The fuel cut off switch is usually and impact type unit to shut off fuel flow in a wreck, but can some times be triggered by a lesser event. Good luck and hope you feel better.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #5 of 14 Old Mar 3rd, 2008, 10:18 pm Thread Starter
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Re: 2002 GMC Yukon XL won't start

all good ideas... thanks, gents... for the help and health thoughts

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
post #6 of 14 Old Mar 4th, 2008, 1:26 am
Senior Member
 
Join Date: Oct 2006
Location: Savannah, GA, USA
Posts: 1,893
Re: 2002 GMC Yukon XL won't start

Well since you say there is no fuel level reading or pump prime I would have to say they forgot to hook the wiring harness to the tank back up. Failing that, look for a fuse near the battery with a pigtail going to the positive cable. That is the fuel pump/ECM fuse. If they didn't disconnect the battery before undertaking the job, they may have shorted one of the wires while removing the pump. If that is the case, be glad it didn't cause the mostly empty fuel tank to go BOOM!
Morley is offline  
post #7 of 14 Old Mar 4th, 2008, 6:31 am
Senior Member
 
bigbear's Avatar
 
Join Date: Dec 2005
Location: Winnebago, IL, USA
Posts: 1,178
Re: 2002 GMC Yukon XL won't start

Channing,
If there is a connector outside of the tank can you carefully check to see if you are getting voltage to pump. Otherwise possible use a stick pin to pierce the wire insulation to get a reading. Not sure how a Yukon is made but on a Ford Crown Vic you can put the fuel pump in sideways or backwards and the sending unit will not work. I know this from experience, ya know stupid is as stupid does....

No power then start checking for the cut off switch normally located in the back of the vehicles buy the wheel wells, fuses etc.

Good luck

Roy

Roy Gregersen

Ride Slow, Ride Fast, Always Ride Safe
85 K100RT sold
02 LTC DOA 9/21/14
12 R1200RT
bigbear is offline  
post #8 of 14 Old Mar 4th, 2008, 8:40 am
Senior Member
 
JPSpen's Avatar
 
Join Date: Jul 2005
Location: Jones, OK, USA
Posts: 3,525
Re: 2002 GMC Yukon XL won't start

The motor won't start until you hear that fuel pump run.

Check the fuse, and the shut off switch. Your manual can tell you where that is.

Mine's on the passenger front kick panel.

Sounds like you're pulling the tank again.

Been there , done that..

Did they just replace the pump or the whole assembly ?

Check wiring to pump and sender. Fuel pumps are a PITA.

Good Luck

John

Live and direct from the new earthquake capitol of the U.S. Jones, Oklahoma
08 Can-Am Spyder (Miss Lindy's)
03 R1200CLC Capri Blue "Flipper"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 R1100RT Glacier Blue "Lucky"
91 R100GS "It'sNotAMoneyPit"
The voices in my head may not be real, But they have some good ideas!


"I like the wind in my face and Boobies on my back. No, Wait, I got that backwards"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JPSpen is offline  
post #9 of 14 Old Mar 4th, 2008, 8:43 am
Senior Member
 
Join Date: Apr 2002
Posts: 14,434
Re: 2002 GMC Yukon XL won't start

Quote:
Originally Posted by cfell
all good ideas... thanks, gents... for the help and health thoughts
Huuuh - what? You didn't teach them boyz about the BFH???

Git well, Bud - full strength Oregano liquid; one drop under the tongue every mornin'. Works for me - most of the time. Cold, flu, and allergies all.
Dick is offline  
post #10 of 14 Old Mar 4th, 2008, 9:26 am
Senior Member
 
zippy_gg's Avatar
 
Join Date: Jun 2004
Location: Kennesaw, GA, USA
Posts: 8,110
Post Re: 2002 GMC Yukon XL won't start

On Kathy's Rover there was a safety shut off valve that was triggered when the car was put on the tow truck (big lean angle). It is designed to shut off the fuel pump if the vehicle rolls over, etc... In her case that safety shut-off vales was in the engine compartment, and all I had to do was to reset it.
You may want to check a Yukon forum and ask the question there, you will probably get more hits...

Gilles & Kathy
BMWMOA# 154719
IBA# 71594
2011 Ostra Gray RT
06 Mercedes-Benz E350 Estate (parts and people hauler)
2012 BMW X3 (parts and people hauler)
86 Porsche 911 Cabriolet (my "new" baby)



For her I climbed the highest mountain!
For her I swam across the deepest ocean!
For her I walked through the largest desert!
And then she left me... She said I was never home!!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zippy_gg is offline  
post #11 of 14 Old Mar 4th, 2008, 12:31 pm
Senior Member
 
Join Date: Oct 2006
Location: Savannah, GA, USA
Posts: 1,893
Re: 2002 GMC Yukon XL won't start

According to my research the Yukon does not have a fuel cutoff switch (I don't know of any GM vehicle that does). As suggested, get a meter and check for power down at the connector. If there is no power there, go to the pump relay and check for power coming out of it, no power, check for power going into the relay. The relay is controlled by the ECM providing a ground to it.
Morley is offline  
post #12 of 14 Old Mar 4th, 2008, 10:57 pm Thread Starter
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Cool Re: 2002 GMC Yukon XL won't start

Thanks for all the input.

I have verified there is power at the Relay. I will verify tomorrow that the relay is working.. I swapped with others and they function in those locations.

Just need to make sure I'm getting power at the pump wiring.

Since I'm not getting fuel to register on the gauge, I'm guessing something is fouled there.. so, I'll be pulling the pump tomorrow.

Here was the way we left it this evening.....

Notice.. no hammers were hurt during removal..
Attached Thumbnails
Click image for larger version

Name:	Tank1.jpg
Views:	4348
Size:	259.2 KB
ID:	16943   Click image for larger version

Name:	Tank2.jpg
Views:	1028
Size:	254.1 KB
ID:	16944  

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
post #13 of 14 Old Mar 5th, 2008, 6:27 am
Senior Member
 
bigbear's Avatar
 
Join Date: Dec 2005
Location: Winnebago, IL, USA
Posts: 1,178
Re: 2002 GMC Yukon XL won't start

Daddy, we there yet......

One match and I bet she will light up

Roy Gregersen

Ride Slow, Ride Fast, Always Ride Safe
85 K100RT sold
02 LTC DOA 9/21/14
12 R1200RT
bigbear is offline  
post #14 of 14 Old Mar 14th, 2008, 9:31 am Thread Starter
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Re: 2002 GMC Yukon XL won't start

oops.. forgot to post the update... and resolution..

Turns out there are several "choices" for fuel pumps... some come with "new"/replacement electrical connectors to "upgrade" your existing.

Well, when all the pump swapping happened, there was confusion and the plug was not considered being a problem.. surely they are all "wired alike".....

They are not.

So, when I started feeling better I was able to find wiring diagrams, then figure them out on the car.... and yes, they were wired correctly on the car, but the pump was different....

FIX...... I had to purchase a new "connector" with attached wiring ($58 at dealer, $36 through my "locally owned" jobber) ....then figure out the correct circuit.... once I did that, I plugged in the pump BEFORE installing into the tank and verified it ran.... also verified the fuel gauge worked...

Installed all including tank and everything workie fine!!!

Lesson(s) learned...

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Alarm went off now bike won't start! blavenia K1200LT 12 Jul 22nd, 2009 10:33 am
Difficult start after refueling Schweintechnik K1200LT 19 Jul 21st, 2009 9:01 pm
Darn thing wont start - any ideas? TWheels K1200LT 17 May 16th, 2007 10:35 am
Help, my bike won't start! zuchero K1200LT 40 Oct 18th, 2006 8:49 pm
Triple BBG-Ride Report murray Ride Tales 8 Nov 20th, 2005 6:34 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome