Indicator off switch problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jul 21st, 2010, 10:16 am Thread Starter
Junior Member
 
Join Date: Jun 2010
Location: HOLSWORTHY, DEVON, ENGLAND
Posts: 6
Indicator off switch problem

This morning my indicator off switch stopped working for just the left hand indicators. I now have to flick the right hand indicator and then hit the off switch for it to work. Any suggestions as to what it could be?
Alanb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jul 21st, 2010, 9:10 pm
Senior Member
 
Join Date: Sep 2007
Location: Anaheim, CA, USA
Posts: 684
Re: Indicator off switch problem

Quote:
Originally Posted by Alanb
This morning my indicator off switch stopped working for just the left hand indicators. I now have to flick the right hand indicator and then hit the off switch for it to work. Any suggestions as to what it could be?
It might help if we knew which model and year you are riding.
XMagnaRider is offline  
post #3 of 3 Old Jul 22nd, 2010, 6:54 am
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Indicator off switch problem

Get a can of spray contact cleaner & give it a good cleaning. It may just have dirt & road grime in it.

Stevie Shreeve
katnapinn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Windscreen Motor Problem, Help! 99 LT rab1967 K1200LT 14 Jul 25th, 2019 11:13 am
Ignition switch problem BLBantz K1200LT 8 Jan 11th, 2014 2:44 pm
Mystery switch ipokebadgers K1200LT 12 Jun 3rd, 2009 12:16 pm
Idle switch location? CharlieVT K1200LT 15 Mar 18th, 2009 5:19 pm
Help with switch idea jarhead354 K1200LT 13 Feb 27th, 2009 11:18 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome