Ignition Advance Unit - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Aug 23rd, 2009, 8:23 pm Thread Starter
Member
 
AngryFlagman's Avatar
 
Join Date: Aug 2008
Location: Gansevoort, New York, USA
Posts: 51
Ignition Advance Unit

I know this is a BMW forum and I do ride a K1200 Lt but.... I'm working on a 1982 Kawasaki Ltd 440 for my mother. I'm changing the clutch side motor cover and had to pull the ignition advance unit off. It came off hard and flew across the garage floor and came apart. It went back together easily but there are these tiny rubber things that came off it and cant figure out where they go. I tried searching the parts fiche web sites and none of them cover the ignition parts. Anyone ever deal with one of these parts before? My local Kawisaki dealer doesnt deal with bikes over 10 years old. Any ideas?

2003 K1200 LT E ( Traded )
1976 Suzuki Gt 185 Adventurer ( Sold )
1982 Kawasaki Ltd 440 ( Leaking oil on shed floor )
1967 Sears Sr 250 (Puch) ( Needs new points )
1996 Kawasaki Ex 250
When I cant ride-
2000 Elgin Pelican
1996 Case 621B
2004 John Deere 624J
2005 Ford Ranger 2wd
Life is short....Ride every thing!
AngryFlagman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS unit gone again plonk K1200LT 9 Jun 17th, 2011 4:06 am
When I turn ignition on fuel pump keeps running, can't start?? su_jumptd K1200LT 20 Feb 18th, 2009 7:37 pm
Removing the Radio Control unit 2x4nyc K1200LT 8 Feb 19th, 2008 12:18 pm
If anyone cares, CIP 10.0 is out eljeffe K1200/1300GT (The Next Generation) 13 Oct 30th, 2007 8:42 am
Shell ADVANCE synthetic motorcycle oil in USA 2006 TimVipond K1200LT 5 Dec 7th, 2005 11:03 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome