Front Channel Audio Out - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old May 20th, 2006, 9:54 pm Thread Starter
Junior Member
 
Join Date: Oct 2003
Location: , ,
Posts: 5
Front Channel Audio Out

My front R & L channel audio was intermittent for a couple of days and then went out completely. Both rear speakers are fine. Any suggestions?
OdysseyMed is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old May 20th, 2006, 10:45 pm
Senior Member
 
Join Date: Feb 2004
Location: , ,
Posts: 4,905
More than likely, your speakers aren't fried...nor is your amp fried. You're probably just a victim of oxidized audio connectors. Have you taken apart and cleaned any connectors yet? Also, once clean, use dielectric grease on all connections . . . both audio and electrical. It's great stuff. Found at any local auto parts store.

HTH
messenger13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Garmin 2730 audio connection to Autocom wcarter GPS 5 Jan 8th, 2011 9:12 am
Garmin 26xx/27xx audio problem bmwhd GPS 17 Apr 2nd, 2010 10:32 am
Rear brake squeal linked to front brakes? Vince_nj1 K1200LT 19 Apr 2nd, 2006 10:37 am
Radar Detector Audio With Voice II Options rexray Intercom, CB, & 2-Way Radios 14 Mar 9th, 2006 8:32 pm
V1 Remote Audio Adapter meese Radar Detector 7 Feb 21st, 2006 4:54 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome