Battery Issue? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Mar 14th, 2012, 10:18 pm Thread Starter
Senior Member
 
razman10's Avatar
 
Join Date: Aug 2008
Location: West Greenwich, RI, USA
Posts: 540
Battery Issue?

Went to start my 04LT yesterday for the first time since mid-December. It's been on the tender the whole time and light (on the tender) is green.

The bike would not start! All the lights on the "dash" came on and the servo brake sound kicked in but it would not start (the first time I turned the key to on, the servo sounded funny and remained on until I turned the key to the off position, subsequent times it sounded normal). There was no sound at all from the starter; the bike would not even crank.

Question: can the battery have a "full charge" and yet not be strong enough to crank or start the bike? Or is my issue something else? I know I'm living on borrowed time with the battery, I've had the bike for 4 years and it was already on the bike when I bought it.

Any help will be appreciated! Thank you!!!

__________________

Ray "Razman"

2004 BMW K1200LTE - Rosie (As in Whole Lotta Rosie)
1996 HD Sportster XLH883 Hugger (sold)
1986 Honda Interceptor VF500F (sold)

Your chosen perspective changes everything. - Unknown Author

"You are what you repeatedly do. Excellence is not an event - it is a habit." - Aristotle; 384-322 BC, Greek Philosopher and Scientist
razman10 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Mar 14th, 2012, 10:50 pm
Junior Member
 
Anthonydematteo's Avatar
 
Join Date: Jul 2004
Location: Saratoga Springs, NY, USA
Posts: 16
Re: Battery Issue?

Same thing happened to me yesterday. Tender was green went to start it and no go. I had to bump start it to see if the battery charged after an hour of riding. Came home shut it off and it wouldn't start. I went to Max BMW, spoke with parts guy and said this happens when the battery starts to die it doesn't have enough juice to crank. I installed the new battery tonight and It started right up! My battery was last installed in the fall of 2009.

Tony



2004 Black K1200LTC
Anthonydematteo is offline  
post #3 of 3 Old Mar 17th, 2012, 6:22 pm Thread Starter
Senior Member
 
razman10's Avatar
 
Join Date: Aug 2008
Location: West Greenwich, RI, USA
Posts: 540
Re: Battery Issue?

Thank you Anthony!

That's what I figured. I ordered a new battery and it should be here next week sometime; can't wait!!!

I can say my battery lasted a little longer than yours! The battery was already on the bike when I bought it back in 2008.

Thank you again!

Regards,
Ray

__________________

Ray "Razman"

2004 BMW K1200LTE - Rosie (As in Whole Lotta Rosie)
1996 HD Sportster XLH883 Hugger (sold)
1986 Honda Interceptor VF500F (sold)

Your chosen perspective changes everything. - Unknown Author

"You are what you repeatedly do. Excellence is not an event - it is a habit." - Aristotle; 384-322 BC, Greek Philosopher and Scientist
razman10 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery or Alternator Issue? Docsigmund K1200/1300GT (The Next Generation) 5 Jan 28th, 2009 6:36 pm
Battery charger question PhantomK12LT Batteries, Chargers, & Electrical 5 Jul 24th, 2008 2:38 pm
Battery Concern please advise Hulkster Batteries, Chargers, & Electrical 8 Feb 6th, 2006 12:41 am
How NOT to treat your battery.... Zotter Batteries, Chargers, & Electrical 8 Nov 22nd, 2005 1:51 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome