Battery Charger Hooked Up Wrong - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Sep 6th, 2010, 10:46 am Thread Starter
Junior Member
 
Join Date: May 2010
Location: Maple Grove , MN, USA
Posts: 5
Battery Charger Hooked Up Wrong

Went to ride Bike after sitting idle 2 weeks and Battery was dead. Hooked up my combo Starter/Charger as I have done in the past and noticed almost immediately, after hooking up leads and powering up, I Brain Farted big time and connected Charger Leads backwards . Unhooked quick as possible. No smoke or smoke smell. Checked and found all fuses not blown. Went and bought new Battery and installed. Now getting ABS normal start up noises grinding at all times key turned on. Alarm LED not turning on all of the time upon initial power up. Bike Computer displaying -22 F and --:-- when toggling between other BC options, and naturally Bike not starting. Radio does not display or play either.

How much damage have I caused. Hoping some components protected.

Lastly I had just replaced Factory Radio ($$) as Left Channel was failing and added Dice for iPod (worked fabulously during trip to Black Hills), I assume I have more than likely smoked new Radio.

This Forum has been a fabulous resource for me since I bought my 2004 LT new 6 years ago and hoping for some input as to possible damage from Forum Mechanics

Dale
dvhansen17 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Sep 6th, 2010, 12:14 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,434
Re: Battery Charger Hooked Up Wrong

What type of 'new battery' --- lead acid; gel; AGM? Is it fully charged? When you turn on the key, do you hear the fuel pump energize? Just looking for some answers that might help the wrenchers.

Edit; might consider dropping this over in the K1200LT forum - more hits over there by the wrenchers.
Dick is offline  
post #3 of 3 Old Sep 6th, 2010, 12:25 pm Thread Starter
Junior Member
 
Join Date: May 2010
Location: Maple Grove , MN, USA
Posts: 5
Re: Battery Charger Hooked Up Wrong

Werker AGM Battery fully charged. Bought new one immediately after ##!!** up hoping evrything would be fine. Noise I now continuelly get must be the fuel pump? Sounds just like noise I used to get when turning ignition key to on.

Thanks for the reply and posting advice Dick. Will post on other forum.
dvhansen17 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use a regular trikle charger on my battery? BeemerBoyLT K1200LT 10 Jan 28th, 2010 10:02 am
Battery Charger grassman09 Batteries, Chargers, & Electrical 7 Dec 16th, 2009 12:38 pm
BMW Battery Charger Question mrkolivers RT Series 6 Dec 27th, 2007 8:34 am
Dead Battery: Wrong Charger? ICXC K1200LT 9 Oct 12th, 2006 5:10 pm
Dead battery and car charger TimVipond K1200LT 3 Jan 7th, 2006 7:27 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome