Radio Head Power Problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Apr 11th, 2007, 6:34 am Thread Starter
Junior Member
 
GWBMW's Avatar
 
Join Date: Dec 2006
Location: Winfield, PA, USA
Posts: 19
Radio Head Power Problem

I'm having problem with battery going dead in my 1200LT, and suspect it is related to the radio. When I turn the key on, the radio is already in the 'on' position, even though I have it turned off before turning off the bike.

Anyone else experience this problem?
GWBMW is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Apr 11th, 2007, 6:45 am
Senior Member
 
Join Date: Apr 2002
Posts: 14,434
Quote:
Originally Posted by GWBMW
I'm having problem with battery going dead in my 1200LT, and suspect it is related to the radio. When I turn the key on, the radio is already in the 'on' position, even though I have it turned off before turning off the bike.

Anyone else experience this problem?
Is the radio playing, or just the 'On' button is illuminated? If just the button, then that is normal. If it's playing, that's not normal. Not sure of your model year LT, butt most of 'em have an auto-off feature that activates in 2 hours to kill the radio, in case you leave it playing. So, I'm guessing your battery problem is elsewhere. Trickle charger between rides? How old is the battery - may be time for replacement. HTH.
Dick is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Problem fixed thanks to the HoW... lhamonic K1200LT 8 Oct 20th, 2016 11:30 am
Weird electrical problem with Radio hd2bmw K1200LT 6 Jul 7th, 2010 7:10 pm
Very strange radio problem louatlvc K1200LT 4 Aug 14th, 2006 9:51 pm
Lost power to my radio mkiesel K1200LT 0 Jul 12th, 2006 10:59 pm
Finding power wires on the radio strsout Batteries, Chargers, & Electrical 0 Jan 22nd, 2006 2:44 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome