Electrical plug on 1200LT malfunction - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Nov 3rd, 2006, 7:38 pm Thread Starter
Junior Member
 
Join Date: Mar 2006
Location: , ,
Posts: 5
Question Electrical plug on 1200LT malfunction

Help! I just purchased a 2003 LT with low miles (3800) and the electrical socket on the drivers left front is not working. The socket by the pillion (same side) is fine and the fuses are fine as well. I flipped the cover and the female interior appeared identical to the pillon plug which is working. Need to plug in the
Gerbing for a trip next week anyone have any suggestions? P.S. I am often mechanically challenged but am educable
Thanks
gsguy1950 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Nov 3rd, 2006, 7:40 pm
Gold Supporter
 
Join Date: Jun 2002
Location: Lubbock, TX, USA
Posts: 542
The first thing I would check would be the plug on the back of the connector. It is not unusual at all for that to not get plugged in when the panel was put on.

Jim Davidson
2007 R1200RT
hp1bmw is offline  
post #3 of 4 Old Nov 3rd, 2006, 7:45 pm Thread Starter
Junior Member
 
Join Date: Mar 2006
Location: , ,
Posts: 5
Thank You

I am on my way to the garage, thanks for the prompt sugestion.
Dave Smith
gsguy1950 is offline  
 
post #4 of 4 Old Nov 4th, 2006, 9:33 am
Senior Member
 
SilverBuffalo's Avatar
 
Join Date: May 2005
Location: St. Petersburg, FL, USA
Posts: 3,208
On my bike one of those is hot all the time the other only with the ignition on???


Hans
St. Petersburg FL

2002 K1200LTE
"Silver Buffalo" Totaled 5/06
2005 LT
"Esperanza"
BushtecGenesisTrailer
"Our preferred long distance carrier"



SilverBuffalo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Got a problem!! dcravens K1200LT 14 Oct 7th, 2007 7:02 pm
1200LT vs Harley Street Glide reschwert K1200LT 69 Feb 19th, 2007 1:37 pm
Can I find a male plug for this? GaryEdgar K1200LT 7 Jul 19th, 2006 10:09 pm
trick tool 3/8 in rod coupler (trans plug rep.) zimbazi K1200LT 0 Apr 24th, 2006 10:19 am
2001 LT Radio Accessory Plug midwilshire K1200LT 10 Mar 6th, 2006 6:16 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome