05 K1200LT electrical issues - BMW Luxury Touring Community
Reply
 
Thread Tools Display Modes
  #1  
Old Jun 13th, 2012, 10:21 am
politiri's Avatar
politiri politiri is offline
Junior Member
 
Join Date: Apr 2009
Location: Tara, ONTARIO, Canada
Posts: 9
05 K1200LT electrical issues

Low mileage, ws running great till last fall, even though on BMW tender every night, battery went dead overnight, wouldnt take a carge. Dealer sold me a new battery - on tender every night but went dead in 4 days of no riding, wouldnt take charge again. Warranty battery, then same thing. Dealer had for 4 days and finally tells me BMW had run of BAD batteries this spring, puts another one in, works great for three days (on tender in evenings), no more than 120 miles and 3 days later DEAD again. Been at the dealers for a week now and they cant figure out what is the issue. No accessories on the machine other than OEM and no changes made that would cause electrical draw. Anyone have any ideas, seems that the dealer is at a loss on this one. Contact me direct at iflyprop@gmail.com
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
looking to buy k1200lt, LA, CA powerman5kw South West 28 Sep 23rd, 2013 11:39 pm
k1200LT electrical problem wkane4 K1200LT 2 Nov 16th, 2011 6:25 pm
2005 K1200lt electrical issue stephane K1200LT 8 Aug 4th, 2011 2:00 pm
Dension IceLink Installation K1200LT mcousin iPod/MP3 2 May 30th, 2007 7:33 am
Electrical Problems K1200lt reds K1200LT 2 Apr 5th, 2006 9:47 pm


All times are GMT -5. The time now is 10:52 pm.



BMW Luxury Touring is powered by: vBulletin Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2013, VerticalScope Inc