05 K1200LT electrical issues - BMW Luxury Touring Community
LinkBack Thread Tools Display Modes
post #1 of 1 Old Jun 13th, 2012, 10:21 am Thread Starter
Junior Member
politiri's Avatar
Join Date: Apr 2009
Location: Tara, ONTARIO, Canada
Posts: 9
05 K1200LT electrical issues

Low mileage, ws running great till last fall, even though on BMW tender every night, battery went dead overnight, wouldnt take a carge. Dealer sold me a new battery - on tender every night but went dead in 4 days of no riding, wouldnt take charge again. Warranty battery, then same thing. Dealer had for 4 days and finally tells me BMW had run of BAD batteries this spring, puts another one in, works great for three days (on tender in evenings), no more than 120 miles and 3 days later DEAD again. Been at the dealers for a week now and they cant figure out what is the issue. No accessories on the machine other than OEM and no changes made that would cause electrical draw. Anyone have any ideas, seems that the dealer is at a loss on this one. Contact me direct at iflyprop@gmail.com
politiri is offline  

Quick Reply

Register Now

In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
looking to buy k1200lt, LA, CA powerman5kw South West 28 Sep 23rd, 2013 11:39 pm
k1200LT electrical problem wkane4 K1200LT 2 Nov 16th, 2011 6:25 pm
2005 K1200lt electrical issue stephane K1200LT 8 Aug 4th, 2011 2:00 pm
Dension IceLink Installation K1200LT mcousin iPod/MP3 2 May 30th, 2007 7:33 am
Electrical Problems K1200lt reds K1200LT 2 Apr 5th, 2006 9:47 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome