Radio repaired but now a new problem. - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old May 18th, 2017, 6:28 am Thread Starter
ian
Junior Member
 
Join Date: Jan 2006
Location: Johannesburg South Africa
Posts: 10
Radio repaired but now a new problem.

My radio / CD stopped playing thru the right channel.
I researched the many threads on the forum which indicate a amp failure and duly had the radio repaired.
Refitted the radio and it worked perfectly untill the ignition was switched off. When the bike is started again the radio fails to come on. On disconecting and reconecting the battery it works but then again fails to switch on. Any ideas or thoughts?
Out of interest and possibly related is an issue I have always had with the radio in that if it is switched on very soon after the bike is started it goes into a fail mode where it wont switch on.
The remedy being to disconnect and reconect the battery after which it works just fine.
Any thoughs and your assistance would greatly be apreciated.
ian is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old May 18th, 2017, 6:50 am
Member
 
Join Date: Jan 2017
Posts: 35
Re: Radio repaired but now a new problem.

Try this; turn the key on and radio on, but do NOT start the bike. Let it set 3-5 minutes. Turn the key off for 1 minute, then see if the radio goes into fault. If not, then start the bike and let it run until it reaches normal operating temp at idle. Dont rev it to speed up the temp. Shut the bike off and see if it now goes into fault. If that causes it, check every connection from the battery through the starting circuit. Check for worn, brittle or frayed wires. If all is good, replace the battery and try it all again.

Sent from my SM-G935V using Tapatalk
Travis Handleson is offline  
post #3 of 3 Old May 18th, 2017, 3:20 pm
Member
 
Join Date: Apr 2011
Location: Marion Junction Alabama
Posts: 37
Re: Radio repaired but now a new problem.

I purchased another BMW radio and after it failed, I am installing a SONY MEX=N5150BT radio that is bluetooth compatible and it works with the axxess aswc-1 interface controls module with the resistors added so that my hand controls work. I saw the write up on the forum for a similar one and so far it works great. I will be putting my girl back together and enjoying a 5500 road trip with a radio that works with my iPhone or an android device. It has a CD player as well and it plays music off a memory stick. I am also using some of the buttons on the stingray to make the radio turn on/off, select different outputs for music, choose the radio band and others. By the way, the best part is that handle bar controls still work along with the rear controls.
dvpadgett is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
REPAIRED A SENA HEAD SET PROBLEM Lynn_Keen Chit Chat 4 Feb 25th, 2017 12:45 pm
Radio Problem mtrevelino RT Series 7 Mar 23rd, 2016 3:27 pm
Radio Sound Problem Steveford K1200LT 1 Oct 14th, 2013 10:18 am
Another Radio Problem sh059 K1200LT 1 Jan 16th, 2011 5:22 pm
Radio problem erichotdoc Bike Talk 3 Sep 11th, 2009 11:21 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome