2000 CRUISE CONTROL HELP.... - BMW Luxury Touring Community
 1Likes
  • 1 Post By javenmcd
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Apr 27th, 2017, 5:51 pm Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 13
2000 CRUISE CONTROL HELP....

Hi all....I've just finished several projects to include braided brake lines and the super-stiff throttle cable replacement. Put it all back together and the cruise control no longer works. Ran the diagnostic and the system tells me that the throttle micro switch isn't working. Got the cables to the point that the throttle micro switch is functioning....clutch switch functioning...front brake switch functioning....rear brake switch check fails. Hmmmm....the switch seems to be functioning fine other than that. Rear brake lights function normally and there is an audible "click" when the brake lever is applied and released. I didn't mess with the switch during line replacement. What am I missing? The cruise worked great prior to my "repairs." Any help is GREATLY appreciated....I've spent far more time working on the bike than riding it and I'm starting to get a little frustrated. I want to put it together and ride!!!! Help. 2000 LT with non-integrated ABS.
javenmcd is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Apr 27th, 2017, 8:59 pm
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 2,251
Re: 2000 CRUISE CONTROL HELP....

Quote:
Originally Posted by javenmcd View Post
Hi all....I've just finished several projects to include braided brake lines and the super-stiff throttle cable replacement. Put it all back together and the cruise control no longer works. Ran the diagnostic and the system tells me that the throttle micro switch isn't working. Got the cables to the point that the throttle micro switch is functioning....clutch switch functioning...front brake switch functioning....rear brake switch check fails. Hmmmm....the switch seems to be functioning fine other than that. Rear brake lights function normally and there is an audible "click" when the brake lever is applied and released. I didn't mess with the switch during line replacement. What am I missing? The cruise worked great prior to my "repairs." Any help is GREATLY appreciated....I've spent far more time working on the bike than riding it and I'm starting to get a little frustrated. I want to put it together and ride!!!! Help. 2000 LT with non-integrated ABS.

Is this the procedure you did for diagnostics and did you do it exactly as in the exact order including holding the rear brake for 5 seconds till the light goes out and then releasing and seeing it come back on? Just did this on my 01 and if you mess up a step, you have to start over.

It is possible you have a bind in the cruise cable for routing. I hear things going on under the Tupperwear as I run through so it may be actuating the cruise module and sensing a bind during the rear brake test.

This procedure must be done exactly as follows while you monitor the "SET" light on the instrument cluster:
1) With the ignition switch OFF, switch on the cruise control. Press and hold the cruise control switch to the SET position and switch on the ignition switch (LIGHT)

2) Release the SET button (LIGHT GOES OFF), move the switch to the RESET position (LIGHT)

3) Release the button (LIGHT OFF) switch OFF the cruise control switch (LIGHT)

4) Switch the cruise control switch back on (LIGHT OFF)

5) Rotate the throttle against the throttle stop (LIGHT), release the throttle (LIGHT OFF).

6) Pull the clutch lever (LIGHT), release the clutch lever (LIGHT OFF)

7) Pull the front brake lever, (LIGHT) release the lever (LIGHT OFF)

8) Push the foot brake pedal (LIGHT ON), hold for 5 seconds (LIGHT OFF), release foot brake pedal (LIGHT ON)

9) Rotate the rear wheel (LIGHT SHOULD GO OFF/ON) 10) Switch off the ignition.

Signature
Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride)
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced
bmwcoolk1200 is online now  
post #3 of 8 Old Apr 28th, 2017, 2:37 pm Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 13
Re: 2000 CRUISE CONTROL HELP....

Good catch Sir! I wasn't HOLDING the rear brake switch.....I think it probably helps to be smarter than the machine you're working on which excludes me....
Thanks for the help!!!!
javenmcd is offline  
 
post #4 of 8 Old Apr 28th, 2017, 2:52 pm
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 2,251
Re: 2000 CRUISE CONTROL HELP....

Quote:
Originally Posted by javenmcd View Post
Good catch Sir! I wasn't HOLDING the rear brake switch.....I think it probably helps to be smarter than the machine you're working on which excludes me....
Thanks for the help!!!!
Hope it is all working now.

Signature
Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride)
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced
bmwcoolk1200 is online now  
post #5 of 8 Old May 17th, 2017, 7:33 pm
Senior Member
 
davebullock's Avatar
 
Join Date: Jun 2007
Location: waukesha, WI, USA
Posts: 283
Re: 2000 CRUISE CONTROL HELP....

Fix your Cruise?

48 states
2000 LT 165,000 miles
2007 RT P 42,000 miles SOLD
1982 vision 550 Yamaha SOLD
1964 Vespa 175 w/sidecar (homemade by neighbor) SOLD
1966 Honda CL77 (2016-17 winter project)
Four corner Iron Butt ride
48 state/12 day ride 2016
davebullock is offline  
post #6 of 8 Old May 18th, 2017, 7:01 am
Member
 
Join Date: Mar 2017
Posts: 34
Re: 2000 CRUISE CONTROL HELP....

Quote:
Originally Posted by davebullock View Post
Fix your Cruise?
he must have fixed it ....or sold the bike.
He hasn't been back since. It would be nice to get an update
See him again next problem
red85k100rs is offline  
post #7 of 8 Old May 18th, 2017, 9:48 am
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 2,251
Re: 2000 CRUISE CONTROL HELP....

I think once he did the tests correctly and they all passed, he got on the bike and started riding. He will be back as already suggested for the next thing he needs assistance with.

It's what we do.

Signature
Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride)
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced
bmwcoolk1200 is online now  
post #8 of 8 Old May 22nd, 2017, 5:11 pm Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 13
Re: 2000 CRUISE CONTROL HELP....

Well.....now that you mention it....I thought my last post had clarified. I wasn't doing the test properly. I did get the cruise figured out and put on a whole 110 miles before my ABS lights started alternating. The bike is beautiful and rides well but it is becoming pretty problematic and I've only put 1000 miles on it. Sorry, I just don't spend much time on the forum....I usually find myself reading horror stories about failed drives or knuckleheads that can't figure out their cruise control issues..... Heading back to the main forum now to ask about my ABS....sigh.....thanks all!
bmwcoolk1200 likes this.
javenmcd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Cruise Control - R1150RT LaChuparosa RT Series 9 Dec 29th, 2012 3:08 pm
Cruise control diagnosis = what is this telling me? coug66 K1200LT 9 Feb 5th, 2012 9:06 am
Cruise control blueheaven K1200LT 6 Oct 18th, 2009 8:21 pm
Cruise Control question Beamer007 K1200LT 10 Sep 18th, 2009 8:48 am
Problem with cruise control jdanek K1200LT 1 Jul 30th, 2007 8:12 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome